Apúntate...


Consultas, desarrollo de programas y petición de presupuestos:

domingo, 19 de agosto de 2012

Instalación desde repositorios del sistema / PPA


Para ubuntu y sus derivadas  (linux mint, etc)

Tenemos un PPA para instalar la versión estable de Gambas3:


$sudo add-apt-repository ppa:nemh/gambas3 
        $sudo add-apt-repository ppa:gambas-team/gambas3  
$sudo apt-get update
$sudo apt-get install gambas3


En la distribución de MininoPicaros "Diego" (2013), ya viene incluido preinstalado gambas3.4.2



Y ya estaría instalado

Para Debian


Para debian hay que cambiar de repositorio, usando el "sid"

Lo explico en esta página:

http://jsbsan.blogspot.com.es/2014/07/actualizacion-gambas-354-en-el.html



Archlinux:

https://www.archlinux.org/groups/x86_64/gambas3/


Distribuciones donde ya esta gambas3 instalado:

Distribuciones linux con gambas3 incluida.
Existen distribuciones linux (por ejemplo: minino PicarOs "PICAROS Diego" ), que ya tienen instalado Gambas3.





Notas:
1) Noticia: 6/08/2014
El repositorio de PPA de nemh esta obsolelo, hay que usar para las nuevas versiones el de Sebikul: ppa:gambas-team/gambas3


2) Acerca de otros repositorios
Existe otro ppa, que lo instala desde las versiones de desarrollo no estable ( /trunk )
sudo add-apt-repository ppa:gambas-team/gambas-daily

3) Repositorio Beta: (04/09/2015) Versión previa antes de la salida de una versión estable
https://launchpad.net/~gambas-team/+archive/ubuntu/gambas-beta

14 comentarios:

  1. Hola

    Tengo instalado Debian7 con Gambas 3.1.1

    He instalado tus dos programas y me da el siguiente error al ejecutar:

    ERROR: #2: Cannot load class 'Form1': Bytecode too recent. Please upgrade Gambas.

    Está claro que se debe a la versión de Gambas, pero no consigo instalar la versión que pides.
    Te ruego que intentes hacer el programa para la versión de Debian7 que acaba de salir.

    Un saludo.
    SETA43

    ResponderEliminar
    Respuestas
    1. seta43:
      Debes de tener instalado gambas3.4.1 (y no la version 3.1.1)
      Pasos a seguir:
      1) Desinstalas gambas 3.1.1
      2) He ampliado este post, para explicar tambien como se instala con Debian, sigue los pasos que he indicado.

      Saludos



      Eliminar
  2. Hola, actualmente uso gambas 3 pero la version que viene por defecto en ubuntu, el problema esta en que cuando estoy escribiendo codigo depronto el cursor se queda más atras o más adelante del texto que escribo y me pierdo totalmente, quiero actualizarlo pero desde algun repositorio existente a la fecha de hoy. existe??

    ResponderEliminar
  3. Hola he encontrado la solución al añadir saucy en lugar de lucid como lo indicas en el post, solo que creí que ya no funcionaban porque es un post viejo pero aqui dejo este comentario para que los que encuentren este post no duden, ya que a la fecha funcionan los repositorios solo cambiando lucid por saucy

    ResponderEliminar
  4. holo me agrada tu blocg y el curso quisiera preguntarte que os de linux aparte de minio recomendarias para programar en gambas 3 ya que en ubuntu no lo e podifo hacer por alguna razon no puedo usar caracteristicas como programacion cientifica y otras.

    ResponderEliminar
    Respuestas
    1. ¿que version de ubuntu usas? Instalando el PPA, tienes la última versión de gambas sin problemas.
      Yo uso Debian Sid, y alli se puede isntalar sin problemas Gambas 3.5.4.

      Eliminar
  5. como instalo gambas 3.8.4 en ubuntu 15.10?, gracias.

    ResponderEliminar
    Respuestas
    1. Usando el ppa:
      $sudo add-apt-repository ppa:gambas-team/gambas3

      $sudo apt-get update

      $sudo apt-get install gambas3

      Te va ha instalar la ultima, a fecha de hoy la gambas3.8.4

      Eliminar
  6. Entonces si hay muha diferencia entre el gambas que viene en el centro de descargas de ubuntu y hacerlo con comandos?

    ResponderEliminar
    Respuestas
    1. En Ubuntu 15.04, creo que ya viene gambas3.8.4. Antes en Ubuntu venia la 3.1, y hay mucha diferencia entre esa y la del PPA. Para aprender da igual cual instalar. Normalmente la del PPA es más moderna.

      Eliminar
  7. Hola Buenos días. Muchas gracias por tu programa. Acabo de instalar gambas según tus instrucciones, en mi ubuntu 16. He bajado el tar.gz pero no sé cómo seguir para instalar el programa. Perdón por mi ignorancia. Gracias

    ResponderEliminar
  8. Dando aporte en el hilo de la conversación les informo que en Linux Mint (17.3 - Rosa) se instala por default gambas 3.1.1
    En el repositorio que se indica al inicio, se instalo la versión de gambas 3.8.4 y vaya que hay cambios con la 3.1.1

    Saludos y seguimos en línea.

    ResponderEliminar
    Respuestas
    1. Sergio Vergara Ganado:
      Si, la versión 3.8.4 es muy superior a la 3.1.1 que traen por defecto muchas distribuciones linux. Para instalarla, además de usar PPA, se pueden usar otros métodos (compilarla, cambiar a repositorios mas inestables (rama sid de debian,por ejemplo), etc.

      Eliminar

A falta de donativos... un poco de publicidad