Apúntate...


Consultas, desarrollo de programas y petición de presupuestos:

domingo, 19 de agosto de 2012

SVN (versiones de desarrollo)



Instalar Gambas desde SVN 

(control de versión Subversión).



Esta es la forma de descargarse la última versión "no estable" y en desarrollo de Gambas3.

Primero teneis que instalar subversión en vuestro sistema:

$ sudo apt-get install subversion

Además necesitáis tener instaladas las herramientas de compilación, que dependerá de vuestra distribución. Podéis saber cuales son, en la página  http://gambas.sourceforge.net/en/main.html



 En ubuntu 12.04 son:

 $ sudo apt-get install build-essential autoconf libbz2-dev libmysqlclient-dev unixodbc-dev libpq-dev libsqlite0-dev libsqlite3-dev libgtk2.0-dev libcurl4-gnutls-dev libgtkglext1-dev libpcre3-dev libsdl-sound1.2-dev libsdl-mixer1.2-dev libsdl-image1.2-dev libxml2-dev libxslt1-dev librsvg2-dev libpoppler-dev libpoppler-glib-dev libxtst-dev libffi-dev libqt4-dev libglew1.5-dev libimlib2-dev libv4l-dev libsdl-ttf2.0-dev libgnome-keyring-dev libgdk-pixbuf2.0-dev linux-libc-dev libgsl0-dev libgstreamer0.10-dev libgstreamer-plugins-base0.10-dev

Y luego descargaros la versión de la rama de desarrollo (trunk) de gambas3:

$ svn checkout https://gambas.svn.sourceforge.net/svnroot/gambas/gambas/trunk/


Y nos vamos al directorio trunk 
$ cd trunk
 
Y ahora la compilariamos:
$ ./reconf-all
... 
$ ./configure -C 
... 
$ make 
... 
$ sudo make install 
...

 Y asi tendríamos ya instalada en nuestro ordenador la última versión de Gambas 


Podeis ver más información de las versiones existentes  en esta url:


Fuentes:





No hay comentarios:

Publicar un comentario en la entrada

A falta de donativos... un poco de publicidad